Findmall.com
 
 






Teknetics Forum


Welcome! Log In Register
Re: T2 Classic Setting Knob Acting Up?
Posted by: Fish N Chips
Date: January 02, 2016 06:07PM
It went off today, even USPS ran me 45 dollars with all the add-ons (insurance, certified, ect.) that Teknetics recommends, ouch. At least I did not have to drive 30 miles to drop it off. I look forward to getting it fixed, returned and get back to hunting with it. I am glad I have more than one detector for situations like this. For all the T2s out there, I do not read of too many issues with them. I am sure it was just a fluke thing that surfaced when it finally got cold here. I am going to put an O ring under the knob like Mega suggested, hopefully that will help seal the encoder a bit more.

Re: T2 Classic Setting Knob Acting Up?
Posted by: Radianman
Date: January 02, 2017 04:24PM
What did it cost for repair ?

Re: T2 Classic Setting Knob Acting Up?
Posted by: chuck, ky
Date: January 02, 2017 05:54PM
Looks like I'm going to have to send mine in. My problem is the push button to change the settings. It doesn't work so I can only hunt in factory pre-set and 1 tone and 10 disc. means I have to constantly watch the screen for a good number. I tried bringing it in to see if the warmer temperatures made a difference but it didn't help.

Re: T2 Classic Setting Knob Acting Up?
Posted by: Fish N Chips
Date: January 13, 2017 08:53PM
Mine was under warranty so it just cost shipping to Teknetics. They replaced the knob, put in a new moisture pack and changed out the screen due to some minor scratches (they did this on their own and was not part of the issue). Great service and I have not had an issue with the machine since the repair.

Re: T2 Classic Setting Knob Acting Up?
Posted by: CousinEddie
Date: January 14, 2017 07:56PM
I've had the T2 SE in the past and I know run a T2 Classic. BOTH units did this when they are in colder temps.

Sorry, only registered users may post in this forum.

Click here to login