Findmall.com
 
 






New User Forum Sponsored by Kellyco


Welcome! Log In Register
Bad threshold and volume:twodetecting:e pot(s) on blue Excalibur 1000
Posted by: Golchaser
Date: September 12, 2015 10:44PM
I need to find a supplier for the threshold pot and also the volume pot for a 2006+ Excalibur 1000 (blue) .Anyone help me with this,please?

avatar
Trey Keith Wills
Posted by: vlad
Date: September 13, 2015 12:41PM
at East Texas Metal Detectors in Gilmer, Texas--maybe he can help if ML can't.

Re: Trey Keith Wills
Posted by: Golchaser
Date: September 13, 2015 08:52PM
Got any leads for Excal replacement pod(s) or repair options?
Thanks
Goldchaser

Re: Bad threshold and volume:twodetecting:e pot(s) on blue Excalibur 1000
Posted by: chuck, ky
Date: September 13, 2015 09:15PM
I don't think Keith Wills works on minelabs but you can check with him. if you're just wanting the parts check with minelab, if you want it repaired check with Kellyco.

Re: Bad threshold and volume:twodetecting:e pot(s) on blue Excalibur 1000
Posted by: Golchaser
Date: September 14, 2015 09:56AM
Thanks Chuck.
I hear taht theses are great machines but if I cant get the threshold tone lowered I cany find anything smaller than my scoop.
Goldchaser

Re: Bad threshold and volume:twodetecting:e pot(s) on blue Excalibur 1000
Posted by: GeorgeinSC
Date: September 14, 2015 03:37PM
Check with Oldbeechnut on the todays finds forum and the Excalibur/sovereign forums. He is very knowledgeable on the Excalibur detectors.



Minelab Sovereign GT With an assortment of coils
Garrett Pro Pointer
Leche digging tool
Minelab Excalibur II
T-Rex 9.5 wet sand scoop

Re: Bad threshold and volume:twodetecting:e pot(s) on blue Excalibur 1000
Posted by: treasure_hunter
Date: September 15, 2015 08:59AM
You can send it to Kellyco, they are The Minelab Repair center for US now..... Minelab does not sell parts so the only way to get a new part is to send it in.

Re: Bad threshold and volume:twodetecting:e pot(s) on blue Excalibur 1000
Posted by: Golchaser
Date: September 17, 2015 10:15PM
Well after some online research on OBN, I have the required information to allow me to attempt a "pot" repair on my BLUE 1000.
The video Joe does on You Tube is a very well instructed item, I will follow the instructions as taught.
The "pot(s) were a little harder to aquire.
But thanks again to Joe, he had posted the specific product number (39SA-1RB-103-ND), which will allow all of us trusting souls to do some of our own threshold and volume switch replacements.
I got the 'pots' from:

Digikey.com
701 Brooks Ave south,
P.O.Box 67 Thief River Falls,Mn 56701-0677

I will work on this later tomorrow & post results after I complete.
Thanks Joe, you have provided some of the best vid's I have seen on the Excals repairs & mods..

Re: Bad threshold and volume:twodetecting:e pot(s) on blue Excalibur 1000
Posted by: Golchaser
Date: September 20, 2015 10:30AM
Thanks Treasure _hunter.
Did the repair and all is well.
A lot more difficult than the video I watched. But i guess if you do a lot of them, theye get easier.
Hard to hold the board in place without some type of device to mount it on while working.

Re: Bad threshold and volume pot(s) on blue Excalibur 1000
Posted by: Golchaser
Date: September 27, 2015 12:16AM
Just back from the beach in Florida (Lido Beach) found another simulated diamond......would be nice if Wal Mart sold real rings...but that how it goes.....better than a sharp stick in the eye.
Found (2) genuine diamond rings earlier last month and I suppose that is about par for the beach's I hunt on central Florida's west coast.
There are quite a few metal detectorist that work Clearwater and Ft Desoto.
Out of everwhere I could live,I believe Florida is the best state to find valuable jewelry on most any day you go out and swing the hoop.
I Love my Excal 1000 Blue.
All the hours of work and the information that Ol Beach Nut has posted for us amatuers, really helped me to be a better detectorist.

Re: Bad threshold and volume pot(s) on blue Excalibur 1000
Posted by: GeorgeinSC
Date: September 28, 2015 12:30PM
Glad to see that you got your machine fixed. I sent mine to Kellyco three weeks ago and am waiting for them to clear the backlog of in excess of 60 machines that were there ahead of mine.

I am very hesitant to try to work on one without having any test equipment or electronic manuals to help diagnose the problem. From my conversations with Kellyco I may have cracked the coil.



Minelab Sovereign GT With an assortment of coils
Garrett Pro Pointer
Leche digging tool
Minelab Excalibur II
T-Rex 9.5 wet sand scoop

Re: Bad threshold and volume pot(s) on blue Excalibur 1000
Posted by: treasure_hunter
Date: September 29, 2015 09:35AM
Quote
GeorgeinSC
Glad to see that you got your machine fixed. I sent mine to Kellyco three weeks ago and am waiting for them to clear the backlog of in excess of 60 machines that were there ahead of mine.

I am very hesitant to try to work on one without having any test equipment or electronic manuals to help diagnose the problem. From my conversations with Kellyco I may have cracked the coil.

George, pm me your name and the machine type and I will check on your repair...

Re: Bad threshold and volume:twodetecting:e pot(s) on blue Excalibur 1000
Posted by: Golchaser
Date: October 09, 2015 11:21PM
Well, I have found 7 rings and misc change and costume jewelry.
The new pot works a hell of a lot better than the factory.
They have a very distinct click and are nice to feel the smooth operation when adjusting.
Thinking of replacing all the pots with aftermaret parts.
Looks like another great weekend to hit the water,here in Florida.

Re: Trey Keith Wills
Posted by: bklein
Date: January 07, 2016 12:32AM
I purchased two faulty Excalibur board sets without pots. I was also given example pots - but bad ones.
The pots I received were 100K with switch and 10K without switch. I have never seen a complete Excalibur so I don't know for sure what each installed pot is and its value. The pot being discussed here (39SA-1RB-103-ND), is a 10K with switch - my examples have no switch - only the 100K's have a switch. For a 100K with switch the part number would be a 104 not 103.
So please someone, help clear this up for me: is the complete pot set made of three 100K pots with switches and two 10K without or is it some other mix?
Does it differ between models - how do I tell what my board sets are from?

Barry

Sorry, only registered users may post in this forum.

Click here to login