Findmall.com
 
 






Minelab Excalibur & Sovereign Forum


Welcome! Log In Register
Re: EXCAL 1000 DOESN'T SOUND ON DETECTION
Posted by: sullivan2002
Date: February 14, 2019 02:47AM
I know Joe and he helped me a lot. Before opening my Excalibur I need to have more info as possible.
I have some experience on soldering and electronic devices but Minelab Excalibur is not a simple device, it is a water-proof hermetic device and everything must be done with care, otherwise you risk ruining everything. For this reason I'm trying to get as much information as possible not to go random, I think my case is unique because I have not found other similar cases.
Of course I made some tests, now I'm sure it's not a battery problem even though the battery lasts a little and is to be changed, this is because I made tests powering my Excalibur to an external power supply of 13volt. I don't think it's the coil, the coil has no sign of damage on it. Also cable is in good condition. The problems could be the pot, or something inside the box.


SubjectAuthorViewsPosted

EXCAL 1000 DOESN'T SOUND ON DETECTION Video Attachments

sullivan20022044February 13, 2019 08:18AM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

LawrencetheMDer98April 07, 2019 08:44PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION Jpeg Attachments

sullivan200296May 20, 2019 09:14AM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

bklein80May 27, 2019 10:51AM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

sullivan200268May 28, 2019 03:56AM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

bklein65May 30, 2019 09:39AM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

surfman157February 13, 2019 10:09AM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

Rick(ND)160February 14, 2019 03:06PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION Jpeg Attachments

bootyhoundpa157February 13, 2019 04:46PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION Jpeg Attachments

sullivan2002154February 16, 2019 12:13PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

sullivan2002139February 16, 2019 01:54PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

sullivan2002141February 13, 2019 07:21PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

Ron from Michigan145February 13, 2019 09:00PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

sullivan2002146February 14, 2019 02:47AM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION Video Attachments

sullivan2002149February 13, 2019 07:25PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

Ron from Michigan152February 13, 2019 06:57PM

Re: EXCAL 1000 DOESN'T SOUND ON DETECTION

sullivan2002168February 13, 2019 07:08PM



Sorry, only registered users may post in this forum.

Click here to login