Findmall.com
 
 






Minelab Excalibur & Sovereign Forum


Welcome! Log In Register
avatar
Re: need help/advise/trouble shooting...
Posted by: Rick(ND)
Date: May 24, 2019 01:58AM
My impression with the volume and threshold could be the battery is giving you a low battery alert as the volume gets loud and threshold does nothing at all. If you have the alkaline pack make sure they are fresh batteries and see what it can do. Now if you only have the rechargeable pack make sure it is charged up. Make sure you don't use the rechargeable in the alkaline pack as it only holds 8 batteries
as the rechargeable only have 1.2 volts each so like the factory pack has 10 in it to get the 12 needed.
I don't have my Sovereign here at the computer, but the coil cable should go to the switching box of the S1 probe, then the cable from the S1 probe goes to the DTI meter and the cable coming out of the meter will connect to the Sovereign control box.. I
don't know if it is recommended but I do it quick like to just turn on the control box with nothing connected to the box as it should run very smooth, if not the problem is in the control box which sounds like a low battery alert if the battery is weak. If it runs smooth with nothing connected to the control box then the coil, the meter or the S-1 probe has a problem.
Check it out and let us know what you find out. by process of elimination.


Rick


SubjectAuthorViewsPosted

need help/advise/trouble shooting...

Marc(NB)225May 23, 2019 05:59PM

Re: need help/advise/trouble shooting...

Ron from Michigan80May 24, 2019 08:42PM

Re: need help/advise/trouble shooting...

Rick(ND)78May 24, 2019 01:58AM

Re: need help/advise/trouble shooting...

Marc(NB)71May 24, 2019 11:05AM



Sorry, only registered users may post in this forum.

Click here to login