Findmall.com
 
 






Minelab Safari/Quattro Forum


Welcome! Log In Register
Quattro Help
Posted by: gonzo1968
Date: February 17, 2018 08:00AM
I am having an issue with my Quattro not wanting to turn on. I changed the batteries and cleaned the connectors. When it does finally work, it goes haywire throwing all kinds of numbers.

avatar
Re: Quattro Help
Posted by: kschae4
Date: February 17, 2018 04:04PM
It should be like all the Minelabs. Just press and hold the power button till it says reset...GL 7 HH
http://www.minelabowners.com/forum/showthread.php?31964-safari&highlight=facotory+reset



Minelab Safari/BH Land Star/ Garrett Pro-Pointer
"Cause down the shore everything's all right"
Oldest identifiable coin- 1775 King George lll half penny
Most bizarre find: http://www.findmall.com/read.php?3,1835200,1835200#msg-1835200

avatar
Re: Quattro Help
Posted by: Goldstrike
Date: February 17, 2018 06:59PM
Seems like you may have 2 issues going on? I would also suggest holding down the power button for a reset but also you might want to check your coil to see if it doesn't have any magnetic material i.e. if you have done some beach detecting, check for magnetite or 'black sand' which is iron oxide that you might come across on some beach's (especially Sothern California beach's). That will also cause the symptom that you describe.

Re: Quattro Help
Posted by: gonzo1968
Date: February 18, 2018 10:51AM
I did a factory reset. Will try it in a few days. I clean the coil after each use, so hoping it just needed a reset.

Re: Quattro Help
Posted by: halfstep
Date: May 05, 2018 11:15AM
Also, if you have a skid plate on your coil, take it off and clean the dirt out of it.

Sorry, only registered users may post in this forum.

Click here to login