Findmall.com
 
 






Feedback Forum


Welcome! Log In Register
Repair Center Request - No Shafts Sent Into Repair Center
Posted by: treasure_hunter
Date: April 18, 2016 09:25AM
My hunting partner who works in the Minelab repair center at Kellyco has requested I post this ....

Please DO NOT ship ANY detector shafts to repair center, especially Excalibur's shafts unless your shaft is broken and under warranty.... It will save you on shipping charges to and from repair center and will save you on labor as well as it takes time to take detectors off and put back on the shafts..... If you have an excal with a pinpoint mod take the detector off the shaft and send just the handle with the switch...Repair center has shafts to test with.....

On The E Series like Explorers, Safari, Etrac, if the shaft has an issue with the pressure block then just send the upper shaft with the pressure block, not the lower shaft... If lower shaft has issue with pressure block then just send that.....

avatar
Re: Repair Center Request - No Shafts Sent Into Repair Center
Posted by: u2robert
Date: May 26, 2017 06:46PM
Yes I was just at kellyco and was told the same thing don't bring detector in with shaft.

Re: Repair Center Request - No Shafts Sent Into Repair Center
Posted by: Jaycoe
Date: January 21, 2018 03:25PM
My cover on the power cord to the coil is dry rotted. Connections are all hard wired but I can’t find location to send for repair. I live in Northeast Florida.

avatar
Re: Repair Center Request - No Shafts Sent Into Repair Center
Posted by: surfman
Date: January 22, 2018 09:20PM
What detector do you have?



Been in the detecting hobby for almost 20 years. Currently using; Minelab CTX3030 w/stock and 6" coils. Teknetics T2+. For beach and water I have two Minelab Excaliburs.

Oldest Copper; 1694 King William&Mary

Oldest Silver; 1792 Half Reale

Gold Coin; 1852 $1.00 (Found with ATPro)

YouTube Channel; surfman1968

Re: Repair Center Request - No Shafts Sent Into Repair Center
Posted by: Dan(NM)
Date: January 23, 2018 09:09PM
Quote
Jaycoe
My cover on the power cord to the coil is dry rotted. Connections are all hard wired but I can’t find location to send for repair. I live in Northeast Florida.
. Have you tried contacting Minelab directly, they will give you all the information you need. That's where you start the ball a rolling.

Sorry, only registered users may post in this forum.

Click here to login