Findmall.com
 
 






Minelab CTX 3030 Detecting Forum


Welcome! Log In Register
avatar
Re: xchange 2
Posted by: sgoss66
Date: February 06, 2018 09:26AM
AHH...so ESD killed your power supply, and then you got a new power supply but used the old cables, and that caused the other issues?

I'm sorry it happened. Hopefully, you get it all straightened out, and you can get XChange2 working properly for you.

Steve



Minelab CTX 3030
Minelab Equinox 800
Garrett ProPointer AT
Lesche hand digger
Lesche 38D Ground Shark "King of Spades"

Norman, OK

Re: xchange 2
Posted by: bklein
Date: February 12, 2018 01:26AM
The story continues.... I forgot to screw the USB cap back on and just detected all day today.
No underwater dunking that I remember but I was in the ocean knee deep and water did have a chance to spray all over the detector.
I saw the cap flopping around and ... damn.
So I blew at it and put it on and 2 hours later came home and looked at it.
Green gunk on some USB pins. I sprayed de-oxit on it and it cleaned off the green crud pretty well. Looked at it with a magnifier and tried to get as much of it out of there as possible.
I am leaving the cap off overnight for things inside the connector to dry.
I took the housing apart to check if water had gotten inside - no. I don't see how that can happen unless the black plastic nut isn't tight. A missing cap could allow the USB pins to get hosed but I don't think water will get to the other side through there. There is an epoxy looking stuff all around the back and the wires.
I have yet to try again to connect the CTX to my pc to see if the new Exchange2 works for me.

Sorry, only registered users may post in this forum.

Click here to login