Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

Time Ranger false high tones

bigolhorns

New member
Allot! I've been detecting for twenty plus years, I know how to set up a detector. New Time Ranger Falses (high tone that disappears) on just about every swing. Sensitivity on minimum, Ground reading of around 70, presets 1,2 or 3. Tried eliminating L1,L2,L3,L4 & foil. Changed to my Land Star coil. New Batteries. Seems like it is giving a false high tone on rejected iron with the first pass of the coil. Any ideas or just send it back?
 

bigolhorns

New member
Thanks for the reply! It is just one way. Slower swing helps but it is still happening. I can take the LS over the same area and it is silent with sens. maxed. Is the TR that much more sensitive??
 
Top