Find's Treasure Forums

NOTICE:
This new forum is now ACTIVE. You should be able to log in using the same username and password however if your username contain a comma then you need to log in on the new forum without the comma in your username
Example:
SteveB Main, Mo
remove the comma like this
SteveB Main Mo


If you have any questions or need assistance with this, click here to go to Find's Support Desk form


IF YOU ARE NOT ABLE TO LOG IN, CLICK HERE TO RESET AND HAVE NEW PASSWORD EMAIL TO YOU

Anyone using the larger type coils on G2+,GBP or f19

Tried my detech ultimate 13 for the first time today encountered a lot of EMI using this coil on my f19..
Was wondering if anyone using the larger Nel,Cors type coils with the G2+..Gold Bug Pro/Se or f19 encounter EMI at times...
Thank You for Your time. joe
 

D&P-OR

Active member
Tried my detech ultimate 13 for the first time today encountered a lot of EMI using this coil on my f19..
Was wondering if anyone using the larger Nel,Cors type coils with the G2+..Gold Bug Pro/Se or f19 encounter EMI at times...
Thank You for Your time. joe
Joe------I have owned/used the 13" Ultimate coil on both the G2+ & F-19.-----I suppose it may be the area you are hunting but I have used this combo in both parks & fairgrounds with good results & no worse emi than when using the 7X11" stock coil.------I don't know about the other makes of large coils---but the 13" Ultimate has worked well for me & in the areas I have used it (and without excessive emi).------You might try/compare the Ultimate to your 7X11 & see what the difference is in this regard----should give you some idea if you have a (coil) problem or not.---As to depth---you should get 1" to 1 1/2"more depth with the Ultimate (compared to the 7X11")----I know you are concerned with emi but just thought I would throw the depth difference out there.------Bottom line----with the Ultimate coil--emi should not be a problem when used with the F-19/G2+.--------------Del
 

jmaclen

Member
I have never experienced any EMI with the Detech 13" Ultimate coil on my F19. It can make ground noise louder from high mineralization.
Did you factory reset your F19/G2+ after putting on the Ultimate and did you do a ground grab ground balance in all metal?

Jeff
 

dfmike

Active member
Same here. I never encountered EMI with the Ultimate and F19. In fact in the many years I have used the F19 I only had EMI once. I often use the Mars Tiger as well and never had a problem with that one either.
 
Hey Guys
Greatly appreciate the info...I did not do a reset..that could be it...and also there is a electric substation not far from site..Bet .that could be part of it...never run a coil as big as the ultimate13 on a detector..so wasnt sure what to make of the noise..
Really Appreciate all the help Guys..thank You for Your time. joe
 

D&P-OR

Active member
Hey Guys
Greatly appreciate the info...I did not do a reset..that could be it...and also there is a electric substation not far from site..Bet .that could be part of it...never run a coil as big as the ultimate13 on a detector..so wasnt sure what to make of the noise..
Really Appreciate all the help Guys..thank You for Your time. joe
No prob Joe.----Let us know how it works out for you.-------Del
 
Top