Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

Bounty Hunter Land Star problem?

Phil66

Member
Bought a used Land Star.Worked fine after setup.Second time I took it out.It just beeps constantly in all metal mode.No ajustments work. Other modes no sound nothing..Just wondering if anyone has had such a problem?Would like to avoid sending it in.So thought I would ask.How found a whole lot of smart detector folks on here. Any ideas.?
Thanks Phil
 

Ronstar

Well-known member
Check batteries first thing. Mine did that once and batteries were just low. Otherwise no idea.
 

Ronstar

Well-known member
I got nothing……
 

Phil66

Member
Update!I looked at the price to send the unit in and was on the fence about it being as much as I paid for the unit. Looked at solutions and decided to try diffrent brand of batteries.My old eyesight is not so good anymore.Noticed a green ring around one terminal very light.Closer inspection showed a lot of green in the inside of terminal.A small bottle cap filled with vinegar was used to soak the connector in,added a little baking soda. I then used a tiny ,tiny flat head screw driver to scrape it off after the soaking.Guess what, works fine now.I often ask questions,feel good I have a solution this time.
 

Ronstar

Well-known member
The problem went full circle and back to you! Now get out there and find those goodies!!!
 

Draco

Well-known member
Ron was right. Problem with the batteries, in this case, the connection😉
 
Top