Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

Large screen appears when Exp II is turned on

BigTony

Active member
For the last two months when I turn on my Exp II the first screen is the large numbers screen and I don't understand what is happening.
It started after I applied a iPhone screen plastic cover, the digitable numbers were large right from the start. So I hit a button to advance to another screen and it's back to normal.
Also at this same time sometimes when switching back and forth between digital and display screen the machine will not show the target box.
I have to toggle backl and forth to reset the screens.
I have removed the screen glare plastic but it still happening. I know it's old but I still love using it.
Any ideas?
 

IDXMonster

Well-known member
Factory reset the machine Tony. If that doesn't help I'm not sure what you've got going on....
 

BigTony

Active member
IDX, yeah I understand but that is not my favorite option. I love the machine the way it is working now except for these two issues.
I might consider saving this set up over another program.
Thanks Tony
 

BigTony

Active member
IDX, you are the MAN as they say because you were right.
I wrote down all my current settings and then hit reset then of course I made my adjustments.
I went over some park ground and the machine worked just fine.
Thank you again. I guess we all don't understand why we need to hit the reset button every year or so.
Makes me wonder if folks just end up purchasing new machines thinking it isn't working well and must be old.
Reset sure makes using this baby much easier, sounds are sharp/clear again.
 

IDXMonster

Well-known member
BigTony said:
IDX, you are the MAN as they say because you were right.
I wrote down all my current settings and then hit reset then of course I made my adjustments.
I went over some park ground and the machine worked just fine.
Thank you again. I guess we all don't understand why we need to hit the reset button every year or so.
Makes me wonder if folks just end up purchasing new machines thinking it isn't working well and must be old.
Reset sure makes using this baby much easier, sounds are sharp/clear again.
Hey Tony,I just saw this after it's been awhile. Glad it's been working well for you. I do not understand the whole reset thing either,there must be something about the computer part of things that either needs its cache emptied or cookies deleted...:lol: Hell man,I don't know. I just know from heartache and crappy operation that if a reset is done things become happy again. Glad you are also...
 

Buddy_TX

New member
OK how do you do a Factory Reset on the EXP II ?
 

BigTony

Active member
Write down your setting, there is a blank form in the rear of the manual. Otherwise, if you don’t have that book just right them down.
Shut it down and then hold the power button until it goes into factory reset.
 

Buddy_TX

New member
Thanks BigTony
 
Top