Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

Off and on imaging!

TallTexan

New member
Hi, yesterday for the first time, my 2500 had periods of "non-imaging" moments. I have had this unit for a couple of months now and this is the first-time I have encountered such a problem. I would get a good signal, then proceed to press the "treasure imaging (pinpoint)" button and there would be nothing on the screen! The unit even would not identify the conductivity of the metal. The sound would be there, but that's all. Any suggestions? This was an on again and off again situation. Thanks........Martin.
 

metalhead

Active member
From one tall Texan to another, sorry to see that you're having troubles with your 2500:(That's a total drag. I dunno:shrug:Maybe try rebooting the machine? If that doesn't work call Garrett. Hope ya get it fixed. I'm sure that Garrett will fix ya up in no time if it comes to that:thumbup:Best of luck to ya!:biggrin:Keep us posted. Happy Hunting!:)
 

TallTexan

New member
Thanks for the info. I am also thinking about buying the infinium. Will this be a good machine for river hunting? Thanks!
 

oldranger

New member
I had a similiar probelm with the 1500

They took it back and sent a new one no ??s
asked...

Love the service ... FYI i was told that a ribbon
inside the hsng had prbably been loose
But they sent a repl tector asap
LOVE the service

THINK SPRING

Ron
Rangers Lead The Way
 
Top