Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

Update?

Mark kus

Well-known member
I tried and I've never had problems but this time I could not get my puck to update so I went back toV0.6
 

relicmeister

Well-known member
0.71 is a winner by most accounts, worth doing but certainly not a rush. Follow instructions paying attention to details like not using USB port 1 for example and must use windows and download updater as administrator. Otherwise goes quickly and offers very worthwhile upgrades.
 

BigTony

Well-known member
If you do read up or watch videos before, I just updated and am having problems
I had Success today! I was able to re-load version 6 on both and paired. Than I re-ran version .71 on both. For whatever reason my coil serial number was incorrect. I used a magnifier and saw it clear. Even two friends who tried to help me didn’t see that. Once I paired the correct one, I had an excelsior moment!
Run as Admin when you get the prompt for headphones - (headphones are off at this point) press the dash (or minus sign)on headphones holding it until you see XP Or count to8 seconds.
I’ll try detecting later but I feel confident now!
Dam thing made me feel dumb after being in computers for 30 years
 

Suncoast Kid

Active member
I still have v0.6 on mine and it does well. I received it with that version when I purchased it. Obviously, v.070 was not so good. I see a lot of improvements and new features with v0.71, but also see a lot of complaints about the tones, paring, and or depth. Some say that they wished they would have kept v0.5 as they did very good with that one. I feel like I'm confused, like I'm waiting on the next update or something.
Same story with the N/M Legend. Everyone is waiting on the next update.
 

Suncoast Kid

Active member
So, I did the update to v0.71. The only problem I ran into was paring the headphones. Just make sure the headphones are off when you update the remote. After the update it will prompt you to pair the headphones. Just make sure they are off to start off with, and when prompted to pair them, just hold down the headphone power button for a little while until you see they are pared. It was quite easy.
Actually, I updated two units and got confused as to which remote went to which coil and to which headphones, but that was just me being in too much of a hurry, eventually I got it figured out. 😁
 

Suncoast Kid

Active member
By the time I got the update completed it was already dark outside, so I got a flashlight and went out to the coin garden. I was reluctant to do the update, but I'm glad I did as I was very happy with the results.
 
Top