Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

whats wrong with my TDI SL

kaolinwasher

Well-known member
when i turn it on it starts moaning and groaning ,in the all or high position But if its in low conductors its fine, ground balance on , i tried moving the frequency knob and it may be silient for a short time but starts getting loud and moaning again , and will not stop this
 
Possibly EMI? I'd take it to a different location and try it. The frequency adjustment won't eliminate most EMI...that's not what it's for.
Jim
 

kaolinwasher

Well-known member
I took it all over it still doing it
 

kaolinwasher

Well-known member
yes , its boxed up and going in for repair, I know they say its made in USA but i think that really means Assembled, the parts come from somwhere else where slaves do the labor and americans get junk , that fails
 

kaolinwasher

Well-known member
and by the way i have never dropped it or missused it in any way
 

kaolinwasher

Well-known member
tried it still no go
 
Top