Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

Any hope for my ailing Garmin265W.???

ralphiejc

New member
My Garmin 265W doesnt turn on..When I hit the on switch `GARMIN`lights up and it says`loading maps`....thats it...(it started with a `freeze up`while navigating).When I connect to the computer and Garmins site it doesnt get recognized(but my Garmin205 does).Is there any future for this unit or do I loose all `my favorites`???(OUCH!!!)..Thanks for any help,Ralph
 

ralphiejc

New member
I opened the unit up and unplugged the battery and let it sit for a few hours..I plugged the battery in and it still doesnt get past`loading maps`.I also tried powering up with the computer..same thing.I also tried to dischargi it,shorting out the power input terminals,without any power source connected.Still`loading maps`when powered up..It wouldnt even give up a `reset`..Wish it was bigger,Id use it for an anchor!!!!..Thank you Mr.K for your input,Ralph
 
Sorry my advise didn't help.

Next thing. Try re-loading the firmware. I know. Easier said than done. If I had it in my hands it could be a bit different... Hard to go from memory... Garmin used to have an option to download the firmware, run the update program and select the unit on hook-up. Not auto selection but kind of forced where YOU tell the computer what unit you have connected. See if you can download the firmware update NOT the web update.
Almost forgot another thing to try;
Try: With the unit off hold down the top right of the screen. While holding, power the unit up. Keep holding as the unit boots up. It may get you to the magic screen. Right top did not work... Try middle top, left top etc. One of these should get it to the basic setting screen that allows to do full reset.
Oh the obvious; have you called Garmin? Some people say that they can actually give good advice over the phone!
 

ralphiejc

New member
Andrew,I tried powering up after having no power all night.I held my finger in all different corners of the screen(garmin said bottom right) to no avail.Id be hard pressed to do that firmware update you advised with my limited knowledge on the computer and the fact that it wouldnt connect.And yes, I did call Garmin and explained the condition-it was like talking to myself!!.Being that it wouldnt mate up with the computer he couldnt help at all.At least this situation caused me to backup my 205 so I dont loose everything`AGAIN`...when I think back my problem might have been self inflicted by not removeing it from the dash when not in use.(Im wondering if it got `toasted`from sitting in the hot car..)Ill be more careful `next time`!. Andrew,thank you so much for all your advice.Im sure we both wish there would have been a better outcome.Ill check it now and then`,just in case`.Ralph
 

edjcox

New member
Here's a radical idea for you.

Put the unit in a plastic bag, seal it tight and place in the freezer for several hours.

Take it out and load the batteries back in and try it....

It might have had a component that expanded or contracted and that component isn't working.... We used to spray liquid air on various chips to find a bad component..
Next thing is to toss it and stop worrying about it, its met its end...:cry:
 
Top