Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

Leaking 800?

Brianc

Member
I purchased a new 800 and it has some black grease leaking out around the screen. Not sure what it is any thoughts? Thanks
 

laplander

Moderator
Staff member
New one on me, contact jamie.moeller@minelab.com for some good warranty service / advice.
Jeff
P.S. share your results if you would
 

IDXMonster

Well-known member
Brianc said:
I purchased a new 800 and it has some black grease leaking out around the screen. Not sure what it is any thoughts? Thanks

Can you post a pic of it Brian? I’m not sure how these things are assembled but it’s possible they use an O-ring between the case halves and some got out...
 

laplander

Moderator
Staff member
I should have add if your in North America. You know what happens when you assume :unsure: Regardless Its not right and you should contact Minelab warranty.
Jeff
 

Jason in Enid

Active member
IDXMonster said:
Brianc said:
I purchased a new 800 and it has some black grease leaking out around the screen. Not sure what it is any thoughts? Thanks

Can you post a pic of it Brian? I’m not sure how these things are assembled but it’s possible they use an O-ring between the case halves and some got out...

No, no o-rings, the case halves are RF-welded. I'm at a loss for what this could possibly be but recommend sending it back.
 

Brianc

Member
Got with Jamie it I now have a new control in my hands! These units are pressurized so there must have been a sealant that did not set or maybe it got to much pressure.
 
Top