Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

Legend locked up.

MuddyMo

Well-known member
I took my new Legend out yesterday and 30 minutes into the hunt it locks up. I got a signal and started working around it then silence. No buttons worked except holding down the power button for 15 to 20 seconds then it finally rebooted. Fortunately it never happened again. Wondered if this happens to others. I never updated it and don't ask what version I have because I don't know how to check.
 

tvr

Well-known member
Don't know if this will help or not. There was a thread on the Legend freezing a little while back. Apparently there was an update that solves it. I don't have a Legend so this is not from personal experience.

 

Ronstar

Well-known member
Upper corner of the screen will have version, ie, 1.05 or 1.06 etc. I had a freeze but figured out it was my own fault, always make sure you push the settings button to get back to the main screen otherwise you will be looking at a specific setting and then the other buttons wont function. Manual advises to hold power button for 30 seconds so betting you held longer than you thought. It was the right thing to do.
 

MuddyMo

Well-known member
It's version 104, that may be the issue. Tried updating but computer said it couldn't open? the download. Wrong driver or something? You pay big $ for a computer and still have to deal with bs. Why the F can't they make thing work without having to fight it every new thing. 🤬🤬🤬🤬🤬
 
Top