Find's Treasure Forums

Welcome to Find's Treasure Forums, Guests!

You are viewing this forums as a guest which limits you to read only status.

Only registered members may post stories, questions, classifieds, reply to other posts, contact other members using built in messaging and use many other features found on these forums.

Why not register and join us today? It's free! (We don't share your email addresses with anyone.) We keep email addresses of our users to protect them and others from bad people posting things they shouldn't.

Click here to register!



Need Support Help?

Cannot log in?, click here to have new password emailed to you

Changed email? Forgot to update your account with new email address? Need assistance with something else?, click here to go to Find's Support Form and fill out the form.

New Patriot

Picketwire

Well-known member
I just sent my new Patriot off for service. I paid to ship it because I didn't send it in within a month although I really haven't used it except to make sure it sounded off on different coins and such. I did notice that the GB was higher than usual. I did not notice the mineralization display didn't work. Basically, I did a quick test and put it away to wait on the small concentric F75 coil. When I thought I could afford the small coil and received it, when installed, the detector would not GB at all; it showed 90+ on the screen and still sounded of when raising the coil like it was too negative. I sent an email on 9/20 and got a reply on 9/25. I really did think that they should pay for shipping because it is defective and the lady who answered the call said no but she would see what could be done about it. I never received a call back.

So if you buy a Patriot and have a problem, be sure to send it back within a month or you will be paying for shipping. I presently own both Omega models, a T2, F2, F19, an Fpulse, and a Gold Bug, but really can't see where I would ever buy a First Texas product again after this experience. I miss Felix. I was quite satisfied when he was there.
 

wildbill!!

Active member
I just sent my new Patriot off for service. I paid to ship it because I didn't send it in within a month although I really haven't used it except to make sure it sounded off on different coins and such. I did notice that the GB was higher than usual. I did not notice the mineralization display didn't work. Basically, I did a quick test and put it away to wait on the small concentric F75 coil. When I thought I could afford the small coil and received it, when installed, the detector would not GB at all; it showed 90+ on the screen and still sounded of when raising the coil like it was too negative. I sent an email on 9/20 and got a reply on 9/25. I really did think that they should pay for shipping because it is defective and the lady who answered the call said no but she would see what could be done about it. I never received a call back.

So if you buy a Patriot and have a problem, be sure to send it back within a month or you will be paying for shipping. I presently own both Omega models, a T2, F2, F19, an Fpulse, and a Gold Bug, but really can't see where I would ever buy a First Texas product again after this experience. I miss Felix. I was quite satisfied when he was there.
I had the same thing happen to me but with the 15" coil for the T2+. the machine won't ground balance, 90 was it. I bought it from Kelleyco and sent it back and got a refund with no problem. I was kinda glad this all happened because it was a very heavy coil and it was hard to swing for very long.
 
Top